Wemos_Node: letzte debug meldung: Packet queued


#1

ich hab 2 x diese Hardware:

Eine läuft schon als 1Ch GW

Die andere möchte ich als Node/Sensor benutzen.
und hab diesen sketch probiert:


Die Serial Asgab sieht so aus:

Started....
Starting WiFi Localisation - TTN
Compiled: Jan 19 2019, 17:01:53
LMIC settings:
- ping disabled
- beacon disabled
- join disabled
- LMIC_FAILURE TO enabled
- LMIC_PRINTF TO enabled
- LMIC_SPI_FREQ set to 
RXMODE_RSSI
Scan done, sort starting!
8 networks found.
...
Best BSSID: 
...
615048: engineUpdate, opmode=0x808
615991: Unknown event: 17
615996: engineUpdate, opmode=0x888
616397: TXMODE, freq=868100000, len=27, SF=7, BW=125, CR=4/5, IH=0
Packet queued
683183: RXMODE_SINGLE, freq=868100000, SF=7, BW=125, CR=4/5, IH=0

ist freq=868100000 Kanal 0 oder Kanal 1 ?
Das GW zeigt keine enpfangenen Pakete :frowning:


#2
 freq=868100000 ist Kanal 0

868100000, 									// Channel 0, 868.1 MHz/125 primary
	868300000, 									// Channel 1, 868.3 MHz mandatory
	868500000, 									// Channel 2, 868.5 MHz mandatory
	867100000, 									// Channel 3, 867.1 MHz Optional
	867300000, 									// Channel 4, 867.3 MHz Optional
	867500000,  								// Channel 5, 867.5 MHz Optional
	867700000,  								// Channel 6, 867.7 MHz Optional 
	867900000,  								// Channel 7, 867.9 MHz Optional 
	868800000,   								// Channel 8, 868.9 MHz/125 Optional

#3

hab das GW auf Ch0 und SF7 eingestellt, jetzt empfängt immer nach den Reset des Nodes genau ein Paket. Vermutlich sendet der Node erst dann wieder wenn sich die WLAN umgebung ändert. Die Doku dazu ist schön ausführlich:


#4

Ohne jetzt in den Sketch zu schauen sage ich mal du empfängst mit einem Single Chanel Gateway dein Node sendet aber auf allen 8 Kanälen.
Der Node sendet die Kanäle alternierend und somit können 7 Sendungen nicht empfangen werden und nur der 8. Durchlauf kann seine Daten absetzen.
Der Node müsste fest auf den Kanal eingestellt werden damit es sauber läuft.

Du kannst das Verhalten im TTN in der Applikation erkennen, dort wird der Frame Counter hochgezählt nur jedes 8. Paket kommt am GW an.

Das TX Intervall ist auf 60 Sekunden eingestellt, also sollte der Node alle 8 Minuten ein Paket an dein GW übertragen können. (8 Kanäle + 60 Sekunden Abstand)


#5

Ja, du hast recht. Ich habe nun ein paar Zeilen “LMIC_setupChannel…” auskommentiert. Dann werden nur noch die Kanäle 0,1,2 benutzt. Inzwischen kommt auch genau jedes dritte Paket nicht nur auf dem Gateway sondern auch in der Application bei console.thethingsnetwork.org an. Das sind schon mal ein paar schöne Erfolgserlebnisse für heute.